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Bienvenue dans la présentation de 1'IDE

(Integrated Dekstop Environment) de ETP Studio-.

ETP Studio par Onur Celebi.

www-etpstudio-com

Présentation par FpgForce

License verifying... Click on New in the File menu to add files in your project.

Project Explorer (S,

oject]
Modules
Tiles
Sprites
Maps
TiBitmaps
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Pour commencer un
nouveau projet:
File > New > Project

Project Explorer (S]

J Modules
& Tiles

J Sprites
J Maps

J TiBitmaps

License verifying... Click on New in the File menu to add files in your project.
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Open... Ctrl+0

Close HERLD B Project Explorer (8]

Tile Chrl+T

Save Project Ctrl+5 Sprite  Ctrl+L
Save Project as... Map
Save File TiBitmap Ctrl+B £ Modules
Save File As... £ Tiles

. J Sprites
Properties £ Maps

J TiBitmaps

License verifying... Click on New in the File menu to add files in your project.
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Open... Ctrl+0
Close HERLD B Project Explorer (8]

Tile Chrl+T

Save Project Ctrl+5 Sprite  Ctrl+L
Save Project as... Map
Save File TiBitmap Ctrl+B £ Modules
Save File As... £ Tiles

. J Sprites
Properties £ Maps

J TiBitmaps

License verifying... Click on New in the File menu to add files in your project.
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En cliquant sur la racine du projet,
vous pourrez modifier les

ropriétés de votre nouveau projet .
prop prol 2 Tiles

J Sprites
J Maps
J TiBitmaps

(hommé MyProject par défaut).

Project Explorer Double click a file to edit it
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Project Explorer O

v

i MyProject

J Modules
2 Tiles

J Sprites
J Maps

J TiBitmaps

§ Y

Project properties

Project name: MyProject
File name on calculator: myprojct
Publishing comment: Made with ETP

On peut donc changer:
- le nom du projet,
v TI89 .
- le nom du programme sur la calculatrice,
- le commentaire qui apparaitra dans les explorateurs sur la
v TI92+ calculatrice,
- et la calculatrice pour laquelle sera compilé le
programme.

Compile for

Project Explorer Double click a file to edit it
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Pour ajouter un nouveau

ici puis choisissez; "'module” Project Explorer

MyProject
&
2 Tiles
J Sprites
J Maps
J TiBitmaps

Project Explorer Double click a file to edit it
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Module Project Explorer (S}
Tle |y

Sprite

Map MyProject
TiBitmap ]
2 Tiles
J Sprites
J Maps
J TiBitmaps

Project Explorer Double click a file to edit it
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&4 Module1
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Project Explorer S

Procedure MAIN:
'The startpoint of vour program

A

iect
Modules
Module
Tiles
Sprites

Le module est donc ouvert et
YOUS pouvez taper
directement votre code.

el

A new module: Module1 was created.  If you want to learn more about ETP-Basic langage, click on Documentation in the Help menu
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Project Explorer S
& Module1 O 60 6
& |dect
Modules
Procedure MAIN: . Ml
. Tiles
'The startpoant of vour program Spiites
Clear
Maps
GrayOn .o
DarkPlane IUn petit exemple de
Font O code qui pourrait étre
Locate 10,10,"ETP is & new step in TI-Programmation” tape.
WMaitKey
GrayOff
v
Bl Il
|

A new module: Module1 was created.  If you want to learn more about ETP-Basic langage, click on Documentation in the Help menu
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Mode

Pour ajouter un
Sprite nouveau "tile" & votre

Map projet.

MyProject

TiBitmap 7 Modules
Module

2 Tiles

J Sprites

J Maps

J TiBitmaps

B Mod... ) O O)

Project Explorer Double click a file to edit it
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For:Tile2 e i Til92 ) 6O 6O Proiect Euplorer ( 4
[ >
71k U
‘ (3 Y10152) - O
L j i MyProject
+ J Modules
& A7 J - 2 Tiles
e Tile2
Ceci ouvre léditeur de tile ou vous pouvez | SPrites
dessiner directement, en utilisant les outils | Maps
<« —> de la palette ci-contre. ] TiBitmaps
J 1 Pour plus d'informations sur l'editeur de tile
regarc!ez la présentation qui lui est
associée.
= I
)
N
v
e

Editing Tile2
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Project Explorer

v

i MyProject
+ J Modules
- 2 Tiles
e Tile2
J Sprites
J Maps
J TiBitmaps

peut étre dessiné.

Un exemple de tile qui \

Editing Tile2
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Project Explorer (A
i MyProject
+ J Modules
. . Tiles
Ici on peu directement &
renommer le tile qui 3
vient d'étre créé en Sprites
cliquant puis en J Maps

laissant une seconde £J TiBitmaps
la souris dessus.

-

Project Explorer Double click a file to edit it
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g i Project Explorer {2
N2 L
i MyProject
& & + J Modules
- 2 Tiles
i etptile
J Sprites
N J Maps %
) 1 J TiBitmaps
= [
)
White
I
]
-
-

Project Explorer Double click a file to edit it
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&4 Module1
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Project Explorer S

Procedure MAIN:
'The startpoint of vour program
Clear
GrayOn
DarkPlane
Font O

Locate 10,10," is a

IGr ayOff dans notre module.

VaitKey On rajoute l'instruction, qui va
permettre d'afficher le tile,

A

<«

iect
Modules
Tiles

i etptile
Sprites
Maps
TiBitmaps

Editing Modulel
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&4 Module1
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Project Explorer O

Procedure MAIN:
'The startpoint of vour program
Clear
GrayOn
DarkPlane
Font O

PutTile 10,20,etptile] |

IXL

Locate 10,10,"ETP is a new step in TI-Prograrmmation™

A

PutTile [x as Integery as Integer, TileName as Tile)

-

</¥l
N

<«

Editing Modulel

On peut remarquer qu'une aide
automatique s'affiche quand on
tape les instructions, elle donne
les arguments et la syntaxe de
linstruction.

Ceci est trés utile lors du
développement.

iect
Modules
Tiles
i etptile
Sprites
Maps
TiBitmaps
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i P Module1 O O 1
M N EOOEL:LOJJ ts;[rilt‘: a i MyProject
TiBitmap votre projet. + £ Modules
Procedure MAIN: - 2 Tiles
'The startpoint of vour program i etptile
Clear
GrayOn J Maps
DarkP lane J TiBitmaps
Font O

Locate 10,10,"ETP is a new step in TI-Prograrmmation'
PutTile 10,20,etptile

WaitKey

GrayOff

| o

Project Explorer Double click a file to edit it
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Sprite2 S Lject Explorer ¢. -

v
=ct

Modules

= Tiles

Sprites

+ ,:'Q Sprite2
Maps
TiBitmaps

Sprite Action Tiles [drag and drop project tiles here to modify this action)

Action:  Action_1 - - -
Add action Change action name

Delete action

Cela a pour effet d'ouvrir le Sprite Editor ou
vous pouvez créer vos sprites en fonction des
tiles.

Pour plus d'informations sur le Sprite Editor
regardez la présentation qui lui est associée.

1 4/ % 1 Action
14 b | | Frame: 1 55:: ::::::

-

Editing Sprite2 Drag and drop project tiles in the 'sprite action tiles' frame. Right click on a tile to edit it
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Project Explorer (&)
2 Module1 O O 1
i MyProject
+ J Modules
Procedure MAIN: + 2 Tiles
'The startpoint of vour program _ . . " - Sprites
Clear En cliquant droit sur nimporte i
quel fichier du Project Mans
GrayOn Explorer vous avez acceés & .y
DarkP lane un menu contextuel qui vous {J TiBitmaps
Font 0O propose plusieurs actions.

Locate 10,10,"ETP is a new step in TI-P
PutTile 10,20,etptile

WaitKey

GrayOff

-

Project Explorer Double click a file to edit it
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File Edit VYiew Tools Run Window Help
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Project Explorer (&)
&1 Module1 O O ﬂ
i MyProject
+ J Modules
Procedure MAIN: + 2 Tiles
'The startpoint of vour program - J Sprites
Clear .('k .
GrayOn 1 Maps Project propert
DarkPlane TiBitmgps Add file
Font 0O aProiect p[?pegies: o-u;fre la boite de dialogue
. ) B es propriétés du projet, :
Locate 10,10, "ETF 1s & new step in TI-Prodr| _aqdfie: permet dajouter un fichier créé Rename fi
PutTile 10,2Z0,etptile ultérieurement au projet.
WaitKey ;_F{hqmove file: Permet de supprimer du projet un
ichier.
- Rename file: Permet de renommer le fichier
GrayOLt Rename file: Permet d le fichi
selectionné.

Project Explorer Double click a file to edit it
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;:I;ite Module1 O O ﬂ
M <_, Pour ajouter une i MyProject
TiBitmap nouvelle "map" + [ Modules
Procedure MAIN| 3YPrOet - B2 Tiles

'The startporme—or—yoor program i etptile
Clear J Sprites
GrayOn (]
DarkP lane & TiBitmaps
Font O

Locate 10,10,"ETP is a new step in TI-Prograrmmation'
PutTile 10,20,etptile

WaitKey

GrayOff

| o

Project Explorer Double click a file to edit it
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s

Map1

Le map editor est donc
ouvert, pour plus
d'information voir la

présentation du map editor.

Loordinates

-

Editing Map1

Put Tile on Map T Put Sprite on Map T Map Properties
ey oy et ey [aee 'y e e e e
ey ey ey [nne 'y et .
ey oy et ey [aee 'y e e e e

i WSS SIS B PSS RS BN i
aEn | I ) aEn anan | N N ) anan aEn | I ) aEn anan
408 , 136

e

v

«C
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D-sd & & )
vode I erojectexplorer ©

Tile —
O O ﬂ
Map
Pour ajouter une TIBitmap, + 1 Modules
Proc@ure WLTN: pour plus d mformatlo_ns H £ Tiles
o regardez la présentation ’

'The startpoant du TIBitmap Editor. J Sprites
Clear - J Maps
Grayon ’ > Map
DarkP lane &J TiBitmaps
Font O

Locate 10,10,"ETP is a new step in TI-Prograrmmation'
PutTile 10,20,etptile

WaitKey

GrayOff

Dl )

Project Explorer Double click a file to edit it
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TiBitmap1 goject Explorer
T TI92+ /200 H MProeat
N -"//O + J Modules
a2 7 + B3 Ties
& 1 Sprites
- + J Maps
) Ce | & TIBR - J TiBitmaps
— =S e la ouvre le TIBitmap o .
? Editor ol on peut directement @ TiBitmap]
I dessiner en utilisant les outils
v o1 - de la palette.

Editing TiBitmap1  159; 33
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Project Explorer S
Cut Chrl+¥ le o e ‘ ﬂ
Copy  Ctr+C Dans le menu "Edit"™ -
Paste  Ctrl+v _ _ _ A | yProject
Select All ChI4A On trouve les fonctions classiques Couper, Copier, Coller, tout £1 Modules
selectionner. £1 Tiles
Find CtrhF oint ofl De plus on peut utiliser les fonctions Rechercher et Remplacer. J Sprites
Replace Ctrl+H J Maps
Les fonctions Undo et Redo sont trés interressantes puisque Undo o
Grayon permet d'annuler la derniére action executée et Redo permet g TlBltmassB' 1
DarkP lane d'annuler la demiere utilisation de Undo. &3 Tiitmap
Font O

Locate 10,10,"ETP is a new step in TI-Prograrmmation'
PutTile 10,20,etptile

WaitKey

GrayOff

Dl )rl

Editing Modulel
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) ~ (& v Ioobar B v #a D

v Status Bar

Project Explorer S
Project Explorer Le menu "iew'" permet de choisir les différents \
21 ] \
Toolbox k composants de la fenétre de I'DE: | O 6 e
Refresh - Toolbar: affiche ou non la barre doutils. A [ yProject
= - Status Bar: affiche ou non la barre de status (en bas de la J Modules
Procedure MAIN: fenétre] . ) _ £ Tiles
'The startpoint of you 1 Project Explorer: permet d'ouvrir la fenétre du project £ Spiites
explorer si elle est fermée.
Clear - Toolbox: affiche la fenétre des outils de dessin. O M'a;':s
GrayOn - Refresh: met & jour les différentes fenétres. J TiBitmaps
DarkP lane ég'ﬁ&mwp1

Font O

Locate 10,10,"ETP is a new step in TI-Prograrmmation'
PutTile 10,20,etptile

WaitKey

GrayOff

Dl )rl

Editing Modulel
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O~ =& =3 & | Stat F9 Dans le menu "Run'
Compile F8 _ _
- Start: permet de faire executer le projet courant sur I'émulateur VYT1.  |ect Explorer &)
accessible aussi par le raccourci F9
&0 Module| | P )

Procedure MAIN:
'The startpoint of vour program
Clear

Grayod
DarkP lane
Font O

PutTile 10,20,etptile

- Compile: permet de compiler le projet courant. (accessible aussi par
le raccourci F8)

Locate 10,10,"ETP is a new step in TI-Prograrmmation'

WaitKey
GrayOff

N

v

Bl == D

Editing Modulel

T odules
2 Tiles
J Sprites
J Maps
J TiBitmaps

t

£ TiBitmap1
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Project Explorer (&)
& M ' () O ﬂ
i MyProject
Dans la barre d'outils on o a M.odules
trouve aussi un raccourci + 0 Tiles
Procedure MAIN: permettant de compiler le £ Sprites
'"The startpo projet courant. £ Maps
Clear + J TiBitmaps
GrayOn
DarkPlane
Font O

Locate 10,10,"ETP is a new step in TI-Programmation®”,4
PutTile 10,20,etptile

WaitKey

GrayOff

Rl >

Project Explorer Converted: 85%
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CFarh Project Explorer (&)
& Mod | | () O ﬂ
. i MyProject
Ce raccourci permet de faire + - [ Modules
executer le programme sur VT + 2 Tiles
Procedure MAIN: £ Sprites
'The startpoin - — £ Maps
Clear + J TiBitmaps
GrayOn
DarkPlane
Font O

Locate 10,10,"ETP is a new step in TI-Programmation®”,4
PutTile 10,20,etptile

WaitKey

GrayOff

Rl >

Project Explorer Converted: 92%
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Project Explorer
e

20 | {3 Debug S ‘

Procedure ‘Compiling. ..
"The COMPILATION SUCCEED

Clear Linking..
GraycC

DarkP
Font

Locat
PutTi

Lorsque l'on compile le projet, la
fenétre de debug s'ouvre
automatiquement et indique les
différentes phases du processus.

-

Linking.. Preparing..
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File Edit VYiew Tools Run Window Help
h-=Ed & ) b
Project Explorer A
e )
20 {3 Debug 3 S ‘

ProceaureéCompiling...

"The  COMPILATION SUCCEED
Clear Linking..

GrayC Linked

DarkP myprojct.89z was successfully created at D:4'TI\Outils PC\Compilateurs, IDE\E’
Font myprojct.9xz was successfully created at D:'TI\Outils PC\Compilateurs, IDE\E’
Locat
PutTi
Waitk
GrayC

Bl— N

i
MAKE SUCCESSFULN
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Cascade

Tile Horizontal
Tile Yertical
Arrange Icons

v 1 Project Explorer

Procedure MAIN: 2 Modulet
'The startpoint of vour program
Clear
GrayOn
DarkPlane

Le menu "Window'"

- Close All: ferme toutes les fenétres ouvertes.
- Cascade: arrange toutes les fenétre en Cascade.
- Tile Horizontal: Etire la fenétre courante honizontalement.
- Tile Vertical: Etire |a fenétre courante verticalement.
- Arrange lcons: re-arrange les icones du project explorer.

>

O O

J Modules
2 Tiles
J Sprites
J Maps

+ J TiBitmaps

in TI-Programmation”,4

B == )

Project Explorer Double click a file to edit it




.- -—r & R
cTP

e ) ‘MyProject - ETP Studio O 6 6

File Edit View Tools Run Help
O = d & Close all >
[ 20 Cascade Module Project Explorer (S
Tile Horizontal ﬁ
Tile Vertical

Arrange Icons
Procedure MAIN:

LR Foiect
. + - [J Modules
'The startpoint of + o Tiles
Clear 2 Module1 J Sprites
GrayOn J Maps

DarkP lane ‘" E + J TiBitmaps

Font O . ~ .
Locate 10, |ci on peut choisir d'afficher ou

. non les fenétres indiquées.
PutTile 1(

WaitKey
GrayOff

i TI-Programmation”, 4

<5 1AV

Project Explorer Double click a file to edit it
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File Edit Yiew Tools Run  Window
O = d & ') Documentation
f 24 News from official website Project Explorer (3]

Yersion ﬁ

Procedure MAIN:

+ J Modules
'The startpoint of yvour program ¥ £ Tiles
cl Le menu "Help": O Spites
Gr ' 1 Maps
Dal - Documentation: ouvre une fenétre avec la + J TiBitmaps

Fo| documentation en ligne.
Lol - MNews from official website: Ouvre une fenétre evc la

- ograrmmation™, 4
page de news du site.

Pul . vVersion: Affiche la version de I'DE.

Wa

GrayOff

Al

oY c—) >

Project Explorer Double click a file to edit it

s
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Project Explorer (S,
La présentation de 1fIDE de ETP Studio est maintenant terminée.
Pour plus dfinformation sur les différents composants de 1'IDE
regardez les autre présentations et leur documentation.
ETP Studio par Onur Celebi.
Wwww-etpstudio.com
Pour toute suggestion ou reclamation concernant la
présentation: fpgforcedetpstudio-com

License verifying... Click on New in the File menu to add files in your project.




	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	

