Accueil Ti-Gen Foire Aux Questions Chat sur le chan #tigcc sur IRC
Liste des membres Rechercher Aide
Bienvenue Invité !   Se connecter             Mes sujets   
Administrer
0 membre(s) et 1 visiteur(s) actif(s) durant les 5 dernières minutes Utilisateurs actifs : Aucun membre + 1 visiteur
Avant de poster sur le forum, il y a des régles de bases à respecter pour une bonne entente et un respect de tous.
Veuillez lire la charte du forum.
  :: Index » Le site » Bugs Portail » Validation du portail (20 réponse(s))
./POST DE DEPART (post n°0)   Marquer comme non lu.
Benjy Ecrit le: Samedi 28 octobre 2006 à 13:59 Déconnecté(e)    Voir le profil de Benjy Envoyer un email à Benjy Visiter le site WEB de Benjy Envoyer un message privé à Benjy  


Bonjour, vous avez mit le logo de validation XHTML en bas de la page hors quand on clique dessus on decouvre qu'il y a 192 erreur et que la page n'est pas consequent pas valide....
Ce le ne fait pas super...
Voila je voulait faire la remarque en passant.
Le langage C y'a pas mieux!!!
    
./Post n°1   Marquer comme non lu.
geogeo Ecrit le: Samedi 28 octobre 2006 à 15:20 Déconnecté(e)    Voir le profil de geogeo Envoyer un email à geogeo Visiter le site WEB de geogeo Envoyer un message privé à geogeo  


En effet. Mais si tu regardes les erreurs se sont que des trucs basiques.
Webmaster du site.
Programmeur sur TI68K. Arkanoid, Nebulus, GFA-Basic.

Plus d'informations sur GFA-Basic (un langage Basic pour TI68K).
http://www.tigen.org/gfabasic
    
./Post n°2   Marquer comme non lu.
Kevin Kofler Ecrit le: Samedi 28 octobre 2006 à 18:51 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


C'est quand-même une utilisation illégale du logo (qui n'est à mettre que sur les sites qui valident!), donc s'il te plaît retire-le. (Tu as de la chance que ce sommes nous qui remarquons et pas le W3C, tu aurais déjà une lettre signée par un avocat sinon.)
-Edité le Samedi 28 octobre 2006 à 18:51 par Kevin Kofler-
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°3   Marquer comme non lu.
Benjy Ecrit le: Samedi 28 octobre 2006 à 21:59 Déconnecté(e)    Voir le profil de Benjy Envoyer un email à Benjy Visiter le site WEB de Benjy Envoyer un message privé à Benjy  


Oui parce que basique peut etre mais il y en a quand meme presque 200!!
Moi j'ai fini la validation total de mon site je sait que c'est du travail mais le merite du logo est la apres. Alors le mettre avec un nombre aussi important d'erreurs....
-Edité le Samedi 28 octobre 2006 à 22:00 par Benjy-
Le langage C y'a pas mieux!!!
    
./Post n°4   Marquer comme non lu.
geogeo Ecrit le: Dimanche 29 octobre 2006 à 04:22 Déconnecté(e)    Voir le profil de geogeo Envoyer un email à geogeo Visiter le site WEB de geogeo Envoyer un message privé à geogeo  


Bon pb corrigé mais j'ai failli bousiller le site car je me suis enmëler les pinceaux dans les fichiers. %)
Sérieux toute façon faut que je rebosses sur le site mais j'ai trop de projets.
La version actuellement 1.0 est vraiment merdique a souhait, je suis d'accord avec vous. Faut que je me force un de ces jours à sortir du tirroir la version 4.

-Edité le Dimanche 29 octobre 2006 à 04:24 par geogeo-
Webmaster du site.
Programmeur sur TI68K. Arkanoid, Nebulus, GFA-Basic.

Plus d'informations sur GFA-Basic (un langage Basic pour TI68K).
http://www.tigen.org/gfabasic
    
./Post n°5   Marquer comme non lu.
Benjy Ecrit le: Dimanche 29 octobre 2006 à 12:49 Déconnecté(e)    Voir le profil de Benjy Envoyer un email à Benjy Visiter le site WEB de Benjy Envoyer un message privé à Benjy  


Enfin en meme temps je te comprend un peu le site est un peu mort un peu comme tous les sites TI qui tournaient bien avant d'ailleur...
Le langage C y'a pas mieux!!!
    
./Post n°6   Marquer comme non lu.
geogeo Ecrit le: Dimanche 29 octobre 2006 à 13:45 Déconnecté(e)    Voir le profil de geogeo Envoyer un email à geogeo Visiter le site WEB de geogeo Envoyer un message privé à geogeo  


Faut attendre la NSpire %) ^^
Webmaster du site.
Programmeur sur TI68K. Arkanoid, Nebulus, GFA-Basic.

Plus d'informations sur GFA-Basic (un langage Basic pour TI68K).
http://www.tigen.org/gfabasic
    
./Post n°7   Marquer comme non lu.
Benjy Ecrit le: Dimanche 29 octobre 2006 à 14:14 Déconnecté(e)    Voir le profil de Benjy Envoyer un email à Benjy Visiter le site WEB de Benjy Envoyer un message privé à Benjy  


Lol ouai.
Sinon tien regarde:
ICI
Mon site 100% valide XHTML et CSS :)
Le langage C y'a pas mieux!!!
    
./Post n°8   Marquer comme non lu.
RHJPP Ecrit le: Dimanche 29 octobre 2006 à 15:45 Déconnecté(e)    Voir le profil de RHJPP Envoyer un email à RHJPP Envoyer un message privé à RHJPP  


Et le mien il est valide XHTML 1.1 :p %)
http://prettyprint.free.fr
    
./Post n°9   Marquer comme non lu.
Benjy Ecrit le: Dimanche 29 octobre 2006 à 16:10 Déconnecté(e)    Voir le profil de Benjy Envoyer un email à Benjy Visiter le site WEB de Benjy Envoyer un message privé à Benjy  


Ouai mais quand on a pas beaucoup de contenu XHTML 1.1 c'est faisable.
Mais des qu'on commence a avoir quelques pages.... XHTML 1.0 deja c'est pas mal!
Le langage C y'a pas mieux!!!
    
./Post n°10   Marquer comme non lu.
geogeo Ecrit le: Dimanche 29 octobre 2006 à 19:25 Déconnecté(e)    Voir le profil de geogeo Envoyer un email à geogeo Visiter le site WEB de geogeo Envoyer un message privé à geogeo  


M'en fout que ça soit compatible ou pas la version actuelle. Comme je l'ai déjà dit j'ai une version 4 qui est compatible xHTML Strict (sans erreur) mais pas encore utilisable dans le sens qu'il manque toujours deux foutus modules.
Je suis sur beaucoup de projets en même temps (recherche de stage au Quebec, Programmation OO jeu d'echecs, site WEB d'entreprise, GFA Basic...).
Ce n'est pas que je n'ai pas envie de reprendre Ti-Gen mais disons que les TI68K ont une priorités bien plus faible que certains projets. Faut me laisser le temps.
Webmaster du site.
Programmeur sur TI68K. Arkanoid, Nebulus, GFA-Basic.

Plus d'informations sur GFA-Basic (un langage Basic pour TI68K).
http://www.tigen.org/gfabasic
    
./Post n°11   Marquer comme non lu.
Benjy Ecrit le: Dimanche 29 octobre 2006 à 20:58 Déconnecté(e)    Voir le profil de Benjy Envoyer un email à Benjy Visiter le site WEB de Benjy Envoyer un message privé à Benjy  


XHTML Strict sans erreur alors tu peut mettre ton DTD en XHTML 1.1...
Ya pas de difference entres les deux.
C'est quoi les modules qui manques?
Le langage C y'a pas mieux!!!
    
./Post n°12   Marquer comme non lu.
Kevin Kofler Ecrit le: Dimanche 29 octobre 2006 à 22:26 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


Mais qu'est-ce que tu en as à battre? Le HTML 4.01 Transitional marche très bien!

Et sinon, c'est débile d'utiliser le XHTML: il y a 2 manières d'envoyer un XHTML:
  • en tant que XHTML: idiot, car IE ne le comprend pas et affiche un arbre XML ou rien du tout
  • en tant que HTML: du coup, c'est parsé par tous les navigateurs comme du HTML 4.01 avec erreurs (les <tag/> avec ce / ne sont pas du HTML 4.01 valide! Enfin, en SGML strict, c'est valide, mais ça ne fait pas du tout ce que ça fait en XML, donc si les navigateurs le parsaient comme prévu par le SGML strict, ça empirerait juste le problème), donc autant le déclarer comme tel!
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°13   Marquer comme non lu.
RHJPP Ecrit le: Dimanche 29 octobre 2006 à 23:43 Déconnecté(e)    Voir le profil de RHJPP Envoyer un email à RHJPP Envoyer un message privé à RHJPP  


Kevin Kofler :
en tant que XHTML: idiot, car IE ne le comprend pas et affiche un arbre XML ou rien du tout

Heu, IE6 affiche très bien le XHTML...
    
./Post n°14   Marquer comme non lu.
Kevin Kofler Ecrit le: Lundi 30 octobre 2006 à 00:48 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


Seulement parce que tous les sites l'envoient avec le mimetype text/html, justement parce que sinon IE ne l'afficherait pas! Si tu l'envoies avec le vrai mimetype XHTML, ça ne marche pas! Or, les autres navigateurs n'activent le mode XHTML strict que si tu l'envoies avec le vrai mimetype, sinon c'est parsé en tant que HTML 4.01 avec erreurs!
-Edité le Lundi 30 octobre 2006 à 00:49 par Kevin Kofler-
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°15   Marquer comme non lu.
RHJPP Ecrit le: Lundi 30 octobre 2006 à 01:33 Déconnecté(e)    Voir le profil de RHJPP Envoyer un email à RHJPP Envoyer un message privé à RHJPP  


OK, je vois.
    
./Post n°16   Marquer comme non lu.
Kevin Kofler Ecrit le: Lundi 30 octobre 2006 à 14:34 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


Et au passage, si les navigateurs font comme ça, c'est parce que ceux d'avant eux le faisaient et donc il y a plein de contenu "XHTML" en ligne qui n'est pas du XML valide et donc s'ils parsaient ça strictement, ils ne pourraient afficher que des erreurs. #roll# (Le XHTML n'est pas censé être comme du HTML, c'est soit c'est valide, soit ce n'est pas valide (et le navigateur n'est censé rien afficher). Donc le XHTML "presque valide", ça ne veut rien dire. Enfin bon, je trouve cette clause de la spécification assez stupide, ce qui est aussi une des raisons pour lesquelles je suis contre le XHTML.)
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°17   Marquer comme non lu.
RHJPP Ecrit le: Lundi 30 octobre 2006 à 14:41 Déconnecté(e)    Voir le profil de RHJPP Envoyer un email à RHJPP Envoyer un message privé à RHJPP  


Kevin_Kofler, quand dans Firefox, je fais bouton droit « Informations sur la page » sur http://prettyprint.free.fr, j'ai : « Mode de rendu : Mode de respect strict des standards. ».
Et la page s'affiche aussi sous IE :)
    
./Post n°18   Marquer comme non lu.
Kevin Kofler Ecrit le: Lundi 30 octobre 2006 à 15:05 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


Parce que tu conditionalises le MIMEtype par navigateur (comme discuté sur IRC).
Et sinon "Mode de rendu : Mode de respect strict des standards." ne veut pas nécessairement dire que le parseur XML strict est utilisé, il faut mettre une erreur dans la page pour tester ça.
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°19   Marquer comme non lu.
Link Ecrit le: Mardi 31 octobre 2006 à 21:51 Déconnecté(e)    Voir le profil de Link Envoyer un email à Link Visiter le site WEB de Link Envoyer un message privé à Link  

Tu veux dire qu'une page en XHTML (avec doctype XHTML et balise root <html> ) est parsée par IE - ou par les autres navigateurs, selon le type MIME - en tant que HTML 4.01 ?
-Edité le Mardi 31 octobre 2006 à 21:51 par Link-
    
  :: Index » Le site » Bugs Portail » Validation du portail (20 réponse(s))
Pages : 1/2     « [1] 2 » »|

.Répondre à ce sujet
Les boutons de code
[B]old[I]talic[U]nderline[S]trikethrough[L]ine Flip Hori[Z]ontallyFlip [V]erticallySha[D]ow[G]low[S]poilerCode [G][C]ite
Bullet [L]istList Item [K] Link [H][E]mail[P]icture SmileysHelp
Couleurs :
Saisissez votre message
Activer les smileys
     

Forum de Ti-Gen v3.0 Copyright ©2004 by Geoffrey ANNEHEIM
Webmaster: Kevin KOFLER, Content Admins: list, Server Admins: Tyler CASSIDY and Kevin KOFLER, DNS Admin: squalyl
Page générée en 60.66ms avec 18 requetes